Jump to content
Sign in to follow this  
b1ohazard

Парочка вопросов

Recommended Posts

Делал по гайду и качал от тудоваже

в итоге неработают аватары, и фоновое изображение

2.png

конфиг сохранён в базе, ( я выбирал там либо в базу либо на сервер)

ещё при первом заходе в конфиг было написано ввести строчку в док constants.php из папки includes, ввёл я следующие (чтобы работал конфиг)

define('PBWOW_CONFIG_TABLE', $table_prefix . 'pbwow_config');

всё включил по гайду, но не аватары ничего не работает, и верхняя строка там сылки в конфиге тоже прописываются.

Помогите кто что знает, или сталкивался с подобной ситуацией

Вот собстна сам форум:

http://wow-ru.com/

Edited by b1ohzard

Share this post


Link to post
Share on other sites

Неотображается не реклама ни чего.....

зашол в конфиг стиля пбвов

там было написано внести в такойто файл строку :

define('PBWOW_CONFIG_TABLE', $table_prefix . 'pbwow_config');

ввёл, конфиг появился... там всё настроил как в инструкциии, и кеш почистил и нефига..

Edited by b1ohzard

Share this post


Link to post
Share on other sites

Либо допущены ошибки при правке кода форума, либо некорректно созданы доп.поля для расы и класса.

может посмотриш? я даже хз код я правил очень внимательно, т.к первый раз ошибался и в этот раз недолжно быть

560380254 или дай свою асю, или скайп, поболтаем по теме.... только пиши с пометкой а то я игнорю спамеров=)))

я тебя добавил, добавься=)

Edited by b1ohzard

Share this post


Link to post
Share on other sites

2 вопроса...

1) Кралья драконьи вокруг аватара на форуме не робят,хоть и включены в админке на модератора,пробовал менять и переставлять на адм или юзера - итог - нет дракоши(((

2) Паленель,где изображена инфа с лвл,аськой и тд. (см. скрин-внизу) видна только мне а не всем пользователям,а чужая инфа не отоюражаеться,даже если кто-то тоже выбрал расу,фракцию и тд, не видно чужим и все...

см. скрин , я попробовал все изложить на примере там...

post-6270-0-80604700-1291066049_thumb.pn

Edited by Mytny

Share this post


Link to post
Share on other sites

1. В инструкции к стилю писалось, что одновременно для группы может применяться только один эффект.

2. При включенной стилизации под близзов данные профиля у группы не показываются. Отключите эффект - и они будут показываться.

Share this post


Link to post
Share on other sites

Проблема такая же как и у топик стартер :unsure: не показываются аватары , лвл , класс и тд. Раза 3 запускал pbwow_rc4.xml и вносил изменения в файлы, постоянно чистил кэш, но результат 1 и тотже. А если нажать на любую "Но чарастер селект" откроется страница с профайлом этого человека где все есть! и аватара и класс и раса. А чисто в темах форума нефига... В чем же проблема блин!? В каком файле я мог ошибится?

Отвечаю сам себе:

Зашел в админку -> Общие -> Нагрузка на сервер и поставить:

Разрешить отображение дополнительных полей профиля в списке пользователей: нет

Показывать дополнительные поля в профилях пользователей: да

Показывать дополнительные поля на страницах тем: да

И потратил на поиск этого простого решения 6 часов... :(

Edited by DRAGONKIR

Share this post


Link to post
Share on other sites

Назрел еще 1 вопрос.

Вот если присвоить спец званию "Оформление сообщений под стиль сотрудников Blizzard" то на форуме у всех у кого это звание не показывается раса класс и пол. 2.png

Как на картинке только вместо ? значок синий blizz.

Скажите в каком файле нужно что то изменить чтоб, помимо того, что на картинке выше еще слево от аватары показывались раса клас и пол, а под "Администратор" показывалось бы еще название гильдии. Чтоб получилось примерно так:

0_576c0_42d3b615_M.jpg

Как так сделать? Что где изменить?

Share this post


Link to post
Share on other sites

Это вам в файле /styles/pbwow/template/viewtopic_body.html надо смотреть и править код ниже

<!-- IF not (postrow.RANK_BLIZZ and S_PBWOW_BLIZZ_RANKS) and postrow.U_POST_AUTHOR -->

(попробовать например убрать условие по рангам близзард)

Share this post


Link to post
Share on other sites

Еще такой вопрос: Как изменить стандартный размер шрифта в сообщениях на форуме? А то когда много текста пишу в посте, читать потом не удобно приходится с помощью тега увеличивать. А как увеличить шрифт не используя этот тег? Копался копался в css файлах стиля и ниче не нашел. Мб не там искал?

Share this post


Link to post
Share on other sites

Спасибо за ответ, но неожиданно появилась еще проблема. Мой бесплатный хостинг стал показывать рекламу которая наезжает на верхнюю часть форуме. У меня стиль катаклизм. Из-за рекламы кусок форума сдвинулся вниз, а ворген с гоблином нет. И отсюда вопрос как мне сдвинуть полностью форум немного вниз чтоб реклама ничего не загораживала?

Вот как это выглядит: http://m4s.elitno.net/phpBB3/index.php

Share this post


Link to post
Share on other sites

Спасибо за ответ, но неожиданно появилась еще проблема. Мой бесплатный хостинг стал показывать рекламу которая наезжает на верхнюю часть форуме. У меня стиль катаклизм. Из-за рекламы кусок форума сдвинулся вниз, а ворген с гоблином нет. И отсюда вопрос как мне сдвинуть полностью форум немного вниз чтоб реклама ничего не загораживала?

Вот как это выглядит: http://m4s.elitno.net/phpBB3/index.php

Поменяй параметр top до нужного значения. Файл style.php

Строки (каждая строка отдельная часть воргена, гоблина) :

.indexbg-bg1 {

top 43

.indexbg-bg2 {

top 75

.indexbg-extra1 {

top -10

.indexbg-extra2 {

top -10

.indexbg-extra3 {

top 43

indexbg-extra4 {

top 77

как то так в общем %) попробуй :)

Share this post


Link to post
Share on other sites

Разобрался. По 1 единичке изменял в top значения пока не соединил все в 1 рисунок и не сдвинул вниз. Только в файле style.php я этого не нашел, а нашел в index_body.html что в папке styles/pbwow :) Вроде думал все, а нет :cry:

Зайдя в любой раздел форума с списком тем, заметил что фон, который обычно подгружается под логотипом WoW из-за долбанной рекламы так и остался на том же месте, как было с гоблином с воргеном.

Вот скрин: СКРИН

А вот мой фон http://m4s.elitno.ne...sm/theme-bg.jpg

Я все обыскал, но так и не нашел ни в 1 файле код этого фона, чтоб его поправить и тоже сдвинуть вниз:unsure: Где же он сидит то блин?

з.ы Сори если уже заебал с своими кривыми руками :blush:

Share this post


Link to post
Share on other sites

Разобрался. По 1 единичке изменял в top значения пока не соединил все в 1 рисунок и не сдвинул вниз

Ну, у каждого свои тараканы :) Я тебе уже готовый вариант для главной страницы написал, а ты по одной единичке менял топы... Ладно :)

На счет всего остального... Смотри по исходному коду страницы, там вроде все понятно :)

Share this post


Link to post
Share on other sites

Я уже наверное достал тут всех своими вопросами, так что заранее извиняюсь за очередной. Решил тут поменять одну из картинок в теме, а именно зеленого гоблина. Нашел хорошую картинку, обработал, нарезал на index-bg1.jpg, extra1.gif и extra3.png, вставил. И довольный полез в cataclysm.css, чтобы подравнять. Но не тут то было, обнаружилось, что изменения в строках


.indexbg-bg1 { background:transparent url('{T_IMAGESET_PATH}/themes/cataclysm/index-bg1.jpg') no-repeat scroll 0 0; width:344px; height:368px; position:absolute; left:-344px; top:0px; }

.indexbg-bg2 { background:transparent url('{T_IMAGESET_PATH}/themes/cataclysm/index-bg2.jpg') no-repeat scroll 0 0; width:385px; height:394px; position:absolute; left:775px; top:0px; }

.indexbg-extra1 { background: url('{T_IMAGESET_PATH}/themes/cataclysm/extra1.gif') no-repeat scroll 0 0; width:216px; height:53px; position:absolute; left:-216px; top:-53px; z-index:6010; }

.indexbg-extra2 { background: url('{T_IMAGESET_PATH}/themes/cataclysm/extra2.gif') no-repeat scroll 0 0; width:272px; height:87px; position:absolute; left:710px; top:-87px; z-index:6010; }

.indexbg-extra3 { background: url('{T_IMAGESET_PATH}/themes/cataclysm/extra3.png') no-repeat scroll 0 0; width:63px; height:176px; position:absolute; left:0px; top:0px; z-index:6010; }

.indexbg-extra4 { background: url('{T_IMAGESET_PATH}/themes/cataclysm/extra4.png') no-repeat scroll 0 0; width:157px; height:101px; position:absolute; left:618px; top:0px; z-index:6010; }

не дают абсолютно никакого эффекта, вплоть до их удаления (кэш обновлял). Облазил все конфигурационные файлы, нашел единственный, который ещё отвечает на эти картинки (точнее в него заглянул сразу, а потом уже на всякий случай обшарил все остальные). В index_body.html

<!-- This part is for the header overlay "extras" on the index page. -->

<div class="index-extras1" style="width:100%; overflow:hidden; position:absolute; height:640px; top:27px;">

<div class="index-extras2" style="margin:0 auto; position:relative; display:block; width:775px; top:92px">

  <div class="indexbg-bg1"></div>

  <div class="indexbg-bg2"></div>

  <div class="indexbg-extra1"></div>

  <div class="indexbg-extra2"></div>

  <div class="indexbg-extra3"></div>

  <div class="indexbg-extra4"></div>

</div>

</div>

Однако, оказалось всё не так просто. Меняя значения расположения в
 <div class="indexbg-bg1"></div> 

единственно что дало какое-то изменение, это указание "style="margin:0 auto;" - картинка сместилась четко по центру. Остальные манипуляции не дали никакого эффекта, как будто картинка является единым целым и жестко где-то привязана.

Прокопавшись целый день, я забросил это не благодарное дело, но любопытство гложет...

Share this post


Link to post
Share on other sites

В файле стилей и задана была жесткая привязка. На что и как вы его правили - неясно. Изменения должны были давать результат. Возможно что если манипулировали со значениями/кэшем на сервере - не обновился кэш в вашем браузере.

Share this post


Link to post
Share on other sites

Вот к примеру меняю


.indexbg-extra1 { background: url('{T_IMAGESET_PATH}/themes/cataclysm/extra1.gif') no-repeat scroll 0 0; width:216px; height:53px; position:absolute; left:-216px; top:-53px; z-index:6010; }

на

.indexbg-extra1 { background: url('{T_IMAGESET_PATH}/themes/cataclysm/extra1.gif') no-repeat scroll 0 0; width:216px; height:53px; position:absolute; left:-116px; top:-33px; z-index:6010; }

. Голова при этом должна сдвинуться право на 100 пикс и вниз на 20 пикс. Но этого почему то не происходит. Кэши обновлял насильно и проверял двумя браузерами. Потому и не могу понять в чём дело...Полтергест, блин, какой-то:)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...