Jump to content

Отображение вовармори


Recommended Posts

О! Спасибо! Извините за косоглазие...))

Еще один вопрос появился:

Как сделать разделы на главной форума как у офф http://pbwow.com/ (то есть и кнопки и разделы). У меня получилось только так: http://www.horde-elite.org/index.php

ЗЫ: Не могу понять как заставить работать:pbarmorycharlink и pbarmoryguildlink

Вставить нормально ссылку тоже не получается т.к. в ссылке - кириллица http://eu.wowarmory.com/character-sheet.xml?r=Ткач+Смерти&cn=Бомбадил

Link to comment
Share on other sites

Для изменения вида разделов на главной в их свойствах в админцентре форума измените тип с категории на форум.

В чем проблема с полями профиля? Если вы их корректно создали, но ссылки не работают, то проверьте, что вы корректно и в полном объеме внесли правки в код файла includes/functions_profile_fields.php

Link to comment
Share on other sites

Для изменения вида разделов на главной в их свойствах в админцентре форума измените тип с категории на форум.

В чем проблема с полями профиля? Если вы их корректно создали, но ссылки не работают, то проверьте, что вы корректно и в полном объеме внесли правки в код файла includes/functions_profile_fields.php

Вроде как с полями разобрался ))

Но после установки вовтултипа появились кракозябры при отображении - http://horde-elite.org/viewtopic.php?f=23&t=3&sid=1a341ae4f72a5ee98f3738be769f79aa ... видимо я что-то с базой начудил?

Link to comment
Share on other sites

Прописал в .htaccess форума строку

AddDefaultCharset UTF-8

По умолчанию в итоге страницы будут открываться в юникоде, если их кодировка не определена.

Не знаю как отблагодарить Вас!

Сам я наверно бы и не справился. Спасибо большое.

Успехов и всего самого наилучшего !

Примного благодарен, Мирослав.

Link to comment
Share on other sites

  • 4 weeks later...

Помогите пожалуйста. Несколько раз делал все по инструкции, и все время вылазит одна и та же ошибка -

Fatal error: Cannot redeclare get_user_avatar_src() (previously declared in K:\home\************\www\forum\includes\functions.php:4515) in K:\home\*************\www\forum\includes\functions.php on line 4630 

Вот сами строки с 4618 по 4631 -

    switch ($avatar_type)<BR>    {<BR>        case AVATAR_UPLOAD:<BR>            $avatar_img = $phpbb_root_path . "download/file.$phpEx?avatar=";<BR>        break;<BR><BR>        case AVATAR_GALLERY:<BR>            $avatar_img = $phpbb_root_path . $config['avatar_gallery_path'] . '/';<BR>        break;<BR>    }<BR><BR>    $avatar_img .= $avatar;<BR>    return $avatar_img;<BR>    }<BR>

Edited by Futtock
Link to comment
Share on other sites

Видимо, вы неаккуратно скопировали кусок кода, в той части инструкции, где говорится о правке файла includes\functions.php (последняя правка для этого файла, вставка куска кода до закрывающей скобки в конце файла). Проверьте, что вы вставили там код один раз, а не дважды.

Если вы уверены, что все сделали там правильно - файл в архив и прикрепите к сообщению в этой теме.

Link to comment
Share on other sites

Видимо, вы неаккуратно скопировали кусок кода, в той части инструкции, где говорится о правке файла includes\functions.php (последняя правка для этого файла, вставка куска кода до закрывающей скобки в конце файла). Проверьте, что вы вставили там код один раз, а не дважды.

Если вы уверены, что все сделали там правильно - файл в архив и прикрепите к сообщению в этой теме.

При изменении кода я заметил, что некоторые уже есть. Сначала я думал так и должно быть, но потом начал заменять - и все равно. Потом скачал оригинальную версию - код вставил и все заработало :). Спасибо.

 

И вот еще вопрос - а в файле "constants.php" строку "define('PBWOW_CONFIG_TABLE',         $table_prefix . 'pbwow_config');" точно надо ставить над "?>" ?

Вот строки -

"define('TOPICS_WATCH_TABLE',        $table_prefix . 'topics_watch');

define('USER_GROUP_TABLE',            $table_prefix . 'user_group');

define('USERS_TABLE',                $table_prefix . 'users');

define('WARNINGS_TABLE',            $table_prefix . 'warnings');

define('WORDS_TABLE',                $table_prefix . 'words');

define('ZEBRA_TABLE',                $table_prefix . 'zebra');

// Additional tables

?>" . Как вы видите, все строки типа "define" находятся выше "// Additional tables". А в инструкции написано, что надо написать выше "?>". 

И еще одна проблема - не видно кнопки выбора дизайна

Edited by Futtock
Link to comment
Share on other sites

Строка // Additional tables - это комментарий, а не часть выполняемого кода.

Делайте как написано в инструкции.

По переключению стилей - проверьте, правку в файл includes/session.php точно вносили?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...